カテゴリ:備忘録( 19 )

 

OpenMediaVault0.5.0.24でSSHログインするまで

OpenMediaVault(debian系)ログイン
Web管理画面でまずは設定
1.デフォルト設定からカスタマイズ→ログインパスワード・LANのIP固定
2.システムアップデート、プラグイン更新
3.WakeOnLAN
4.SAMBA
5.SSHの起動

rootでログイン(サーバー側にて)
1.アップデートと必要パッケージインストール
# apt-get update && apt-get upgrade
# apt-get install aptitude vim tmux

ユーザの追加
・SAMBAなどで使うログイン用ユーザーと端末操作用の管理者用ユーザーを作る
(RHELと違ってWheelじゃないんですね~ちょっと迷った
# useradd -m konayuki ←ユーザー名はお好みで
# passwd konayuki
new pass:
new pass;
# usermod -G -a adm konayuki
# usermod -G -a ssh konayuki←コレ必須(-a付け忘れるとグループ情報上書きされちゃうので注意)
# vi /etc/pam.d/su

# (Replaces the `SU_WHEEL_ONLY' option from login.defs)
# auth required pam_wheel.so
auth required pam_wheel.so group=adm


# useradd sambauser
# passwd sambauser
new pass:
new pass:
# pdbedit sambauser
new pass:
new pass:

sshのログイン
# aptitude show ssh
"State: not install"
あれ~?

# ps aux |grep ssh
"rootXXXX 0.0 0.1 中略 /usr/sbin/sshd"
# ssh -v
OpenSSH_5.5p1 Debian-6(以下略)
有るにはあるので進めます

設定
# mkdir /home/konayuki/.ssh←先ほどsshグループに登録したユーザ分

RSAキーをTeraTermで作成し放り込む

# vim /etc/ssh/sshd_config
Port 22
Protocol 2
AuthorizedKeysFile %h/.ssh/authorized_keys
#HostKey /etc/ssh/ssh_host_key←コメント化
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
PermitRootLogin no
RSAAuthentication yes
PubkeyAuthentication yes
PasswordAuthentication no

サービスの再起動
# /etc/init.d/ssh restart

ここまですればターミナルエミュが動くはず
RHEL系CentOSとは全然違うのは分かってたけどUbuntuServerでやってたこともいまいち通じないとは・・・
[PR]

  by innocenceflower | 2014-05-04 09:58 | 備忘録

UbuntuServer13.10のsamba4ファイルサーバをWindows8対応させてみる

先人たちの知恵によりsmb.confの設定の過去バージョン共通部分は割愛
(UTFやらWorkGroupなど)

おまじない
[global]
max protocol = SMB2

max protocol = SMB3

security = user ←追加

20Mbpsぐらい早くなった・・・気がする
[PR]

  by innocenceflower | 2014-03-30 09:25 | 備忘録

ffmpeg放り込んで活用・・・スクリプト(仮)


#!/bin/bash
FFMPEG="/usr/local/bin/ffmpeg"
FFPRESET_LOCALE="/usr/local/share/ffmpeg/"
LOG_PASS="./pass.log"
LOG_FFMPEG="ffmpeg.log"

INPUT="$1"
OUTPUT==$(basename $INPUT .ts)
[ "${OUTPUT}.ts" = "$(basename $INPUT)" ] || exit 1

#CPU_CORES=0
CPU_CORES=$(/usr/bin/getconf _NPROCESSORS_ONLN)

FORMAT="mp4"
PRESET_NAME="libx264-hq-ts.ffpreset"
VCODEC="libx264"
VCODEC_OPT_X264="-cmp chroma -flags +ilme+ildct -deinterlace -top -1"
OPT_VBRATE=":v 1024k"
OPT_ASPECT="16:9"
OPT_SIZE="hd720"

ACODEC="libfdk_aac"
ACODEC_OPT="-profile:a aac_he_v2 -signaling explicit_sbr"
OPT_ABRATE="24k"
OPT_AFRATE="44100"
OPT_ACHS="2"

FFPRESET="${FFPRESET_LOCALE}${PRESET_NAME}"
VIDEO_JOB="-f ${FORMAT} -vcodec ${VCODEC} -fpre ${FFPRESET} ${VCODEC_OPT_X264} -b${OPT_VBRATE} -s ${OPT_SIZE} -passlogfile ${LOG_PASS}"
AUDIO_JOB="-acodec ${ACODEC} ${ACODEC_OPT} -ab ${OPT_ABRATE} -ar ${OPT_AFRATE}"

${FFMPEG} -i "${INPUT}" -pass 1 -threads ${CPU_CORES} ${VIDEO_JOB} ${AUDIO_JOB} -y "${OUTPUT}.mp4" 2> ${LOG_FFMPEG} \
&& ${FFMPEG} -i "${INPUT}" -pass 2 -threads ${CPU_CORES} ${VIDEO_JOB} ${AUDIO_JOB} -y "${OUTPUT}.mp4" 2>> ${LOG_FFMPEG} \
&& rm -f pass.log*

exit 0

[PR]

  by innocenceflower | 2014-01-05 19:10 | 備忘録

CentOS6.5の初期設定をやろう~その3-LAMPを入れよう(PHP5.5.7を動かす)

Apache2.4.7のデフォルトMPMで動かしPHP 5.5.7を動かす(仮)
PHPを使いたい場合ApacheはPreforkでつかえ(旧)な資料ばかり
いざ入れるとなるとオフィシャルの資料も・・・ん?なので備忘録

お世話になったところ
http://www.kakiro-web.com/linux/php-install.html
http://blog.loadlimits.info/2013/08/ubuntu%E3%81%A7apache-2-4-6event-mpmphp-5-4fastcgi%E3%82%92%E4%BD%BF%E3%81%86/
http://ja.phptherightway.com/


依存関係
Apacheは2.4系入れたので2.2系でビルドされている普通のリポジトリ提供のパッケージは使えないようで
自分のとこの環境に合わせてビルドしなおさないといけないっぽい
なお、毎度おなじみのremiよりソースもらってきて入れる

postfixまたはsendmailを入れる(rootメール読めるように設定済みなので割愛)
その他
# yum -y install libcurl-devel bzip2-devel pam-devel libedit-devel libtool-ltdl-devel \
systemtap-sdt-devel libc-client-devel net-snmp-devel t1lib-devel gmp-devel gdbm-devel \
tokyocabinet-devel libtidy-devel recode-devel

以下のはバージョン縛りあり
libxslt-devel >= 1.0.18
aspell-devel >= 0.50.0
enchant-devel >= 1.2.4
でもbaseでいけるっぽいのでそのまま入れる
# yum -y install libxslt-devel aspell-devel enchant-devel

# yum --enablerepo=epel install firebird-devel libmcrypt-devel
# yum --enablerepo=remi install gd-last-devel libicu-last-devel

# mkdir /usr/local/src/php
# cd /usr/local/src/php
# wget http://rpms.famillecollet.com/SRPMS/php-5.5.7-1.remi.src.rpm
# rpmbuild --rebuild --clean php-5.5.6-1.remi.src.rpm

しかしエラーで落ちるので
以下修正
# vim /root/rpmbuild/SPEC/php-55.spec
%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_sbindir}/apxs}}

%{!?_httpd_apxs: %{expand: %%global _httpd_apxs %%{_bindir}/apxs}}

リトライ
# cd /root/rpmbuild/SPEC
# rpmbuild -bb --clean php55.spec

# cd /root/rpmbuild/RPMS/x86_64/
# ls
php-5.5.7-1.el6.x86_64.rpm php-mbstring-5.5.7-1.el6.x86_64.rpm
php-bcmath-5.5.7-1.el6.x86_64.rpm php-mcrypt-5.5.7-1.el6.x86_64.rpm
php-cli-5.5.7-1.el6.x86_64.rpm php-mssql-5.5.7-1.el6.x86_64.rpm
php-common-5.5.7-1.el6.x86_64.rpm php-mysqlnd-5.5.7-1.el6.x86_64.rpm
php-dba-5.5.7-1.el6.x86_64.rpm php-odbc-5.5.7-1.el6.x86_64.rpm
php-debuginfo-5.5.7-1.el6.x86_64.rpm php-opcache-5.5.7-1.el6.x86_64.rpm
php-devel-5.5.7-1.el6.x86_64.rpm php-pdo-5.5.7-1.el6.x86_64.rpm
php-embedded-5.5.7-1.el6.x86_64.rpm php-pgsql-5.5.7-1.el6.x86_64.rpm
php-enchant-5.5.7-1.el6.x86_64.rpm php-process-5.5.7-1.el6.x86_64.rpm
php-fpm-5.5.7-1.el6.x86_64.rpm php-pspell-5.5.7-1.el6.x86_64.rpm
php-gd-5.5.7-1.el6.x86_64.rpm php-recode-5.5.7-1.el6.x86_64.rpm
php-gmp-5.5.7-1.el6.x86_64.rpm php-snmp-5.5.7-1.el6.x86_64.rpm
php-imap-5.5.7-1.el6.x86_64.rpm php-soap-5.5.7-1.el6.x86_64.rpm
php-interbase-5.5.7-1.el6.x86_64.rpm php-tidy-5.5.7-1.el6.x86_64.rpm
php-intl-5.5.7-1.el6.x86_64.rpm php-xml-5.5.7-1.el6.x86_64.rpm
php-ldap-5.5.7-1.el6.x86_64.rpm php-xmlrpc-5.5.7-1.el6.x86_64.rpm

インストール(要注意)
依存がどえらく面倒に絡まり合ってるので出来た玉から順番に依存関係無視で放り込んでいく
# rpm -Uvh --nodeps php-5.5.7-1.el6.x86_64.rpm php-cli-5.5.7-1.el6.x86_64.rpm \
php-common-5.5.7-1.el6.x86_64.rpm php-devel-5.5.7-1.el6.x86_64.rpm \
php-xml-5.5.7-1.el6.x86_64.rpm php-process-5.5.7-1.el6.x86_64.rpm

php-pearのインストール
http://rpms.famillecollet.com/SRPMS/repoview/php-pear.htmlから最新のバージョンのリンクをゲット
# cd /usr/local/src/php
# wget http://rpms.famillecollet.com/SRPMS/php-pear-1.9.4-23.remi.src.rpm
# ls /var/lib/pear ←なければOK。あったら削除
# rpmbuild --rebuild --clean php-pear-1.9.4-23.remi.src.rpm
# rpm -Uvh /root/rpmbuild/RPMS/noarch/php-pear-1.9.4-23.el6.noarch.rpm

php-pecl-jsoncのインストール
# wget http://rpms.famillecollet.com/SRPMS/php-pecl-jsonc-1.3.3-1.remi.src.rpm
# rpmbuild --rebuild --clean php-pecl-jsonc-1.3.3-1.remi.src.rpm
# cd /root/rpmbuild/RPMS/x86_64
# rpm -Uvh php-pecl-jsonc-1.3.3-1.el6.5.5.x86_64.rpm php-pecl-jsonc-devel-1.3.3-1.el6.5.5.x86_64.rpm

php-pecl-zipのインストール
# cd /usr/local/src/php
# wget http://rpms.famillecollet.com/SRPMS/php-pecl-zip-1.12.3-1.remi.src.rpm
# rpmbuild --rebuild --clean php-pecl-zip-1.12.3-1.remi.src.rpm
# rpm -Uvh /root/rpmbuild/RPMS/x86_64/php-pecl-zip-1.12.3-1.el6.5.5.x86_64.rpm


その他
# rpm -Uvh php-mbstring-5.5.7-1.el6.x86_64.rpm php-mcrypt-5.5.7-1.el6.x86_64.rpm \
php-fpm-5.5.7-1.el6.x86_64.rpm php-mysqlnd-5.5.7-1.el6.x86_64.rpm php-pdo-5.5.7-1.el6.x86_64.rpm

phpの設定
# vim /etc/php.ini
コメントを外し修正
date.timezone =Asia/Tokyo
mbstring.language = Japanese
mbstring.internal_encoding = UTF-8
mbstring.http_input = UTF-8
mbstring.http_output = pass
mbstring.encoding_translation = Off
mbstring.detect_order = auto
mbstring.substitute_character = none

エラー表記
*)テスト環境であったり環境構築中の時などエラー内容がわからんと手がだせないため表示とする
なお、おわったら直しておかないと全世界に恥ずかしいところを晒すことに・・・(エラー内容グーグル検索したらサイトがヒット・・・これは恥ずかしい
1)テスト環境用
display_errors = On
display_startup_errors = On
error_reporting = -1
log_errors = On

2)本番環境用
display_errors = Off
display_startup_errors = Off
error_reporting = E_ALL
log_errors = On

php-mpmの設定
http://www.php.net/manual/ja/install.fpm.configuration.php
# vim /etc/php-fpm.d/www.conf
以下修正
;listen.owner = nobody

listen.owner = apache

;listen.group = nobody

listen.group = apache

;listen.mode = 0666

listen.mode = 0666

Apacheの設定
confファイルのロード
# vim /etc/httpd/conf/httpd.conf
コメント化
#LoadModule mpm_prefork_module lib64/httpd/modules/mod_mpm_prefork.so
コメント外し
LoadModule mpm_event_module lib64/httpd/modules/mod_mpm_event.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so
Include /etc/httpd/conf/extra/httpd-mpm.conf
追記
Include /etc/httpd/conf.d/*.conf


# vim /etc/httpd/conf.d/php.conf
以下修正
<IfModule prefork.c>
LoadModule php5_module modules/libphp5.so
↓変更
LoadModule php5_module lib64/httpd/modules/libphp5.so
</IfModule>


<IfModule !prefork.c>
LoadModule php5_module modules/libphp5-zts.so
↓変更
LoadModule php5_module lib64/httpd/modules/libphp5-zts.so
</IfModule>

# service php-fpm start
# chkconfig php-fpm on
これで一応PHPが動くはず
なおデフォルトのmod_proxy使ったけどロードバランサーでNginxを使うのがトレンドらしいが次の機会に

/*------------------------
http://www.php.net/manual/ja/migration55.deprecated.php
PHP5.5から仕様がかわりpreg_replace()に/e修飾子が使われていると既存のコード内でエラーになるようで
preg_replace_callback()に適宜置き換えていかないといけないらしい
ログがエラーの嵐 orz
------------------------*/
[PR]

  by innocenceflower | 2013-12-30 11:12 | 備忘録

CentOS6.5の初期設定をやろう~その2-LAMPを入れよう(Apache2.4.7)

CentOS 6.5にLAMBを設定その2
今回はApache2.4.7のrpmを作って入れる

http://www.kakiro-web.com/linux/apache-install.html
http://qiita.com/100/items/ab31e57fcc66ac661d5c
http://www.system-act.com/web/apache.html
上記のサイトさんにお世話になりました

# yum -y install doxygen mailcap
# yum --enablerepo=epel install freetds-devel
# yum -y install expat-devel libuuid-devel db4-devel \
postgresql-devel sqlite-devel unixODBC-devel \
openldap-devel openssl-devel nss-devel pcre-devel \
lua-devel libxml2-devel

以下から最新のaprとapr-utilを確認
http://archive.apache.org/dist/apr/


# mkdir /usr/local/src/httpd
# cd /usr/local/src/httpd
# wget http://archive.apache.org/dist/apr/apr-1.5.0.tar.bz2
# wget http://archive.apache.org/dist/apr/apr-util-1.5.3.tar.bz2

# rpmbuild -tb --clean apr-1.5.0.tar.bz2
# cd /root/rpmbuild/RPMS/x86_64/
# rpm -Uvh apr-1.5.0-1.x86_64.rpm apr-devel-1.5.0-1.x86_64.rpm

# cd /usr/local/src/httpd
# rpmbuild -tb --clean apr-util-1.5.3.tar.bz2
# cd /root/rpmbuild/RPMS/x86_64/
# rpm -Uvh apr-util-1.5.3-1.x86_64.rpm \
apr-util-devel-1.5.3-1.x86_64.rpm

# cd /usr/local/src/
# wget http://ftp.riken.jp/Linux/fedora/releases/18/Everything/source/SRPMS/d/distcache-1.4.5-23.src.rpm
# rpmbuild --rebuild --clean distcache-1.4.5-23.src.rpm
# cd /root/rpmbuild/RPMS/x86_64/
# rpm -Uvh distcache-1.4.5-23.x86_64.rpm distcache-devel-1.4.5-23.x86_64.rpm

以下から最新のApache2.4を確認
http://archive.apache.org/dist/httpd/

# cd /usr/local/src/httpd
# wget http://archive.apache.org/dist/httpd/httpd-2.4.7.tar.bz2
# rpmbuild -tb --clean httpd-2.4.7.tar.bz2
# rpm -Uvh httpd-2.4.7-1.x86_64.rpm
# rpm -Uvh httpd-devel-2.4.7-1.x86_64.rpm \
httpd-tools-2.4.7-1.x86_64.rpm mod_ssl-2.4.7-1.x86_64.rpm

初期設定(仮)
・サイトのディレクトリは/home/wwwとする(適宜よみかえて)
・PHPを入れるのでMPMはpreforkにしておく

ディレクトリ
# mkdir /home/www
# mkdir /home/www/htdocs
# mkdir /home/www/cgi-bin

まずはユーザーが作られてるか確認
# cat /etc/group |grep apache
# cat /etc/passwd |grep apache
# usermod -d /home/www
ないとき
# groupadd -g 48 apache
# useradd -u 48 apache -g apache -s /sbin/nologin -d /home/www

以下おのおのの好みで設定
# vim /etc/httpd/conf/httpd.conf

LoadModule mpm_event_module lib64/httpd/modules/mod_mpm_event.so

#LoadModule mpm_event_module lib64/httpd/modules/mod_mpm_event.so
#LoadModule mpm_worker_module lib64/httpd/modules/mod_mpm_worker.so
LoadModule mpm_prefork_module lib64/httpd/modules/mod_mpm_prefork.so


User daemon
Group daemon

User apache
Group apache


DocumentRoot "/var/www/html"
<Directory "/var/www/html">

DocumentRoot "/home/www/html/"
<Directory "/home/www/html/">

Options Indexes FollowSymLinks

Options Includes ExecCGI FollowSymLinks

<IfModule mime_module>
#AddHandler cgi-script .cgi

AddHandler cgi-script .cgi .pl

<IfModule alias_module>
ScriptAlias /cgi-bin/ "/var/www/cgi-bin/" ←最後"/"で閉じ忘れると大変なことになる

ScriptAlias /cgi-bin/ "/home/www/cgi-bin/"

<Directory "/var/www/cgi-bin/">

<Directory "/home/www/cgi-bin/">

最後に設定のテスト

# apachectl configtest

OKが出れば終了
# /etc/rc.d/init.d/httpd restart
# chkconfig --list httpd
# chkconfig httpd on
ランレベルは2~5までonならばOK
[PR]

  by innocenceflower | 2013-12-15 15:09 | 備忘録

CentOS6.5の初期設定をやろう~その1-LAMPを入れよう(LAMPってMySQLだよね?)

CentOS 6.5にLAMPを設定その1
・OraclのMySQL買収によるやる気消滅からOpenSourceなMySQL作者のMariaDBに乗り換え
(PHPMyAdmin他今までのうちのSQL環境は動いたので本格的に乗り換えをやる)
・Apache2.4系をインストール(標準のリポは2.2ベースでコンパイルしてあるのでけっこうめんどいけど)
・PHP5.6をインストール(remiはCentOS標準のApache2.2ベースでコンパイルされているので以下同上)

MariaDBはリポジトリ配布してるので追加
*)初期設定をやろう~その0参考

# yum check-update
# yum update
# yum install MariaDB-compat MariaDB-shared MariaDB-server MariaDB-common MariaDB-client MariaDB-devel

文字化け対策
# vim /etc/my.cnf.d/server.cnf

;エディタで追記
[mysqld]
character-set-server=utf8
;~ここまで

# /etc/rc.d/init.d/mysql start
# chkconfig mysql on
# chkconfig --list mysql
ランレベルは2~5までonならばOK

# mysql_secure_installation
Enter current password for root (enter for none):←空エンター
Set root password? [Y/n] ←空エンター
New password:rootpassword ←自分のとこのrootパスワード
Re-enter new password:rootpassword ←同上
あとは全部空エンター

# mysql -u root -p
MariaDB [(none)]> \s;
MariaDB [(none)]> show engines;
MariaDB [(none)]> show tables;
MariaDB [mysql]> show tables;
MariaDB [mysql]> quit;

コマンドやらアプリはMySQLのときのがそのまんま使えて楽ですね
[PR]

  by innocenceflower | 2013-12-15 14:46 | 備忘録

CentOS6.5の初期設定をやろう~その0-最低限ひつようなものとリポ追加

おせわになったとこ
http://superuser.com/questions/381160/install-gcc-4-7-on-centos

なおOpenSSHの入れ替えは下記のをやるまえにやっとかないと泣く

# yum -y groupinstall "Base" "Development tools"

# yum -y groupinstall "Base"

gccをcernさんとこのSLリポより取得
# rpm --import http://www.scientificlinux.org/documentation/gpg/RPM-GPG-KEY-cern
# wget -O /etc/yum.repos.d/slc6-devtoolset.repo http://linuxsoft.cern.ch/cern/devtoolset/slc6-devtoolset.repo
# yum clean all
# yum check-update
# yum update
# yum install devtoolset-2
確認
# /opt/rh/devtoolset-2/root/usr/bin/gcc --version
適応
# ln -s /opt/rh/devtoolset-2/root/usr/bin/* /usr/local/bin/
# hash -r
# gcc --version

# yum install yum-priorities
/etc/yum.repos.d/CentOS-Base.repo を設定
末尾へ
priority=1

 同じく[base]と[updates]の末尾へ追加(PHPとMariaDB入れない人は無視)
exclude=php* mysql*

これから リポジトリ追加
rpmforge,epel,remi,dag,MariaDB

定番のrpmforge(詳細は多くの先人に任せる)
# wget http://pkgs.repoforge.org/rpmforge-release/rpmforge-release-0.5.3-1.el6.rf.x86_64.rpm
# rpm -ivh rpmforge-release-*.rpm

# rpm --import http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt
# vim /etc/yum.repos.d/dag.repo

;以下おこのみのエディタで書き込み
[dag]
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://ftp.riken.jp/Linux/dag/redhat/el$releasever/en/$basearch/dag/
gpgcheck=1
enabled=0
;~ここまで

# yum --enablerepo=rpmforge -y update rpmforge-release


Fedora
# rpm --import http://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL-6
# rpm -ivh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
# yum --enablerepo=epel -y update epel-release

Remi
# rpm --import http://rpms.famillecollet.com/RPM-GPG-KEY-remi
# rpm -ivh http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
# yum --enablerepo=remi -y update remi-release


MySQL置き換えのMariaDB(OracleはOracleDB飼わせたくてしかたないらしいですんで)
https://downloads.mariadb.org/mariadb/repositories/
よりリポジトリを取得する
# vim /etc/yum.repos.d/mariadb.repo

;以下お好みのエディタにて書き込み
# MariaDB 10.0 CentOS repository list - created 2013-12-15 02:11 UTC
# http://mariadb.org/mariadb/repositories/
[mariadb]
name = MariaDB
baseurl = http://yum.mariadb.org/10.0/centos6-amd64
gpgkey=https://yum.mariadb.org/RPM-GPG-KEY-MariaDB
gpgcheck=1
;~ここまで


# yum clean all
# yum --enablerepo=rpmforge --enablerepo=dag --enablerepo=epel --enablerepo=remi check-update
# yum -y install kernel-headers kernel-devel rpm-build rpm-devel dkms

初期設定をやろう~その1 へ続く
[PR]

  by innocenceflower | 2013-12-15 14:40 | 備忘録

ComiceOS4を入れてみたがChromeが動かん件について

バージョンアップごとに使いにくくなってくGNOMEと
別方向に進化し続けつづけるUnityから使えるGUIをめざし、
グレーゾーンを突き進むおフランス製のUbuntuベースの鳥
Comice OS 4(Pear OS)を入れてみた
4はベータゆえいろいろ手がかかりそうだがそのひとつ

Pear Appstoreで入れたChromeが起動しません
パッケージ不足かとおもいつつ端末で起動すると

/etc/lsb-release: 1: Linux: not found
/etc/lsb-release: 2: Syntax error: "(" unexpected

と出る
ググると海外フォーラムにて同様の事例発見
以下意訳にてメモっとく
/etc/lsb-release: 行 1: Linux: コマンドが見つかりません
/etc/lsb-release: 行 2: 予期しないトークン `(' 周辺に構文エラーがあります

えー
とりあえず元ファイルを別名にてバックアップ

$sudo cp /etc/lsb-release /etc/lsb-release_old

エラー吐いてる文言をさくっと消して保存しとけということで
$sudo vim /etc/lsb-release

DISTRIB_RELEASE=4.0 (build 01a5) ←”()”とその中身を削除して保存

すると普通に起動できるようになる

以上
[PR]

  by innocenceflower | 2012-03-18 09:39 | 備忘録

Firefox5のアップデートにて

日本語化できてなかったので

//Firefox 5.0 AMD64版の日本語化アドオン
http://releases.mozilla.org/pub/mozilla.org/firefox/releases/5.0/linux-x86_64/xpi/ja.xpi

なおFTP配布のようなので32bit版の場合はいつものごとく階層をさかのぼるべし

あと夏風邪にはご注意を
今年は咳と頭痛がひどいようで
[PR]

  by innocenceflower | 2011-07-01 15:23 | 備忘録

UbuntuにてWineその2(書きかけ)

目標はATOK(Win)をUbuntuへ・・・道は険しい
wimeをダウンロード
http://www.venus.sannet.ne.jp/thomas/wime/

てきとうなところに解凍
/usr/local/srcとか

中に入ってmakeする
パッケージ類が足りない場合は足す
インストールはパッケージマネージャ、OSは64bitなので

$ WINEDIR=/usr BIN32=x86 make

でコンパイルが通った
インストール前に
$ LD_LIBRARY_PATH=./so:./io:$LD_LIBRARY_PATH WINEDLLPATH=./dll ./exe/wime
で動作確認・・・wtsapi32.dllはどこだ!?
[PR]

  by innocenceflower | 2010-06-10 12:43 | 備忘録

SEM SKIN - DESIGN by SEM EXE